Ubuntu 14.04 – Samba Restart funktioniert nicht und generelle Samba Probleme nach Update von 12.04 LTS

Nach dem Update von Ubuntu 12.04 LTS auf Ubuntu 14.04 LTS funktionierte mein Samba Server nicht mehr zuverlässig. Mal war er gar nicht hochgefahren, mal funktionierte der Reload nicht usw. Ein für Samba sehr ungewöhnliches Verhalten. Zumal auch in den Logs nichts zu sehen war.

Meine erste Vermutung war, das meine Konfiguration das Problem verursachte obwohl “sudo testparm” keine Fehler gemeldet hatte.
(Mit “sudo testparm” kann man seine Samba Konfiguration auf Fehler überprüfen lassen)

Nach einigen Versuchen mit der Ubuntu 14.04 Standard Konfiguration blieb das Problem trotzdem bestehen.

Die letztendliche Lösung hat mich sehr erstaunt, weil dieses Vorgehen normalerweise in der Linux-Welt nie zum Erfolg führt.
Die Lösung:

 

Fazit

Dieses eher Windows-typische Vorgehen verwundert mich stark und ich hoffe das es “nur” ein kleines Migrationsproblem war. Warum das Problem nach der Neuinstallation verschwunden ist kann ich leider nicht nachvollziehen.

Allerdings scheinen viele Nutzer die von 12.04 LTS auf 14.04 LTS gesprungen sind das Problem zu haben. In manchen Foren haben sich auch User gemeldet, die Ubuntu 14.04 neu installiert haben und trotzdem ähnliche Probleme bei den restarts hatten, was eher auf ein generelles Versionsproblem hinweisen würde. Anyway, es funktioniert jetzt wieder stabil und diese Vermutungen sind nutzlose Spekulation.

0 Kommentare

Dein Kommentar

An Diskussion beteiligen?
Hinterlasse uns Deinen Kommentar!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.